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VV эмулирует следующие устройства: 
 

1. Базовые компоненты: CPU: КР580ВМ80А, КР1821ВМ85А, КР580ВМ1, Z80A, Таймер 
КР580ВИ53, Интерфейсный чип КР580ВВ55А, ПЗУ начального загрузчика (512 байт…32 
кб), ОЗУ 64/128 кб, Видеоадаптер, Клавиатура, Устройства сопряжения с магнитофоном. 

2. Электронный диск 256кб, «Кишинев», улучшенная модель; 
3. Дисковод А: и В: 
4. Sound Tracker или R-Sound (Музыкальный чип AY-3-8910/YM2149F); 
5. Covox (Внешний ЦАП); 
6. Внешний модуль МППЗУ 32кб. 
7. Часы реального времени (RTC) КР512ВИ1. 
8. Джойстик П, С, УСПИД (на дополнительной клавиатуре при включенном режиме «Num 

Lock» и/или на реальном джойстике). 
9. Поддерживаются эффекты мультиколора и растровые эффекты. 
10. Поддерживается эмуляция клонов ПК «Криста-2», «Вектор-Старт 1200», «ПК-6128Ц». 
11. Поддерживается режим эмуляции ошибок программирования палитры. 

 
 
Описание пунктов меню: 
 

* FILE * 
 

File->Open…  
1. Загрузка программ *.ram, *.rom, *.r0m, *.com, *.r?? в память эмулятора и их запуск; 
2. Загрузка сохраненных состояний эмулятора *.sta, которые были созданы ранее опцией 

«Save State» (Имейте в виду, что при такой загрузке содержимое памяти электронного 
диска будет перезаписано!). 

3. Проигрывание музыкальных файлов *.stc, *.stp, *.sqt, *.rmp, *.pt2, *.pt3. 
 
  File->Save As… 
 Сохранение программы загруженной в памяти эмулятора в форматах *.r0m (с нулевого блока), 
*.rom (c первого блока), *.ram (полный дамп памяти); 
 
 File->Config->Load…/Save… 
 Загрузка и сохранение конфигураций эмулятора. 
 
  File->Config ->Presets… 
 Предустановки основных параметров эмулятора (в том числе параметров касающихся звука, 
дисплея и т.п.) рассчитанных на Default, Максимальную производительность и Максимальное 
качество. 
 

File->Drive A: (B:)->Open FDD Image… 
 Загрузка образа диска *.fdd в специально выделенную для этого память эмулятора. 
(Дальнейшие действия производятся с памятью, а не с файлом образом). 
 
 
 



  File->Drive A: (B:)->Open Folder as FDD Image… 
 Открыть папку как образ FDD. (Папка на лету конвертируется в одноименный образ *.fdd, 
после чего этот образ автоматом загружается в эмулятор. Далее все действия производятся с 
файлом образа, а открываемая папка в любом случае остается без изменений). 
 Если в открываемой папке есть файлы, превышающие допустимый размер, они будут 
проигнорированы. Размер папки не должен превышать 800 Кбайт, в противном случае какие то 
файлы будут проигнорированы. Если имена файлов длинные, они преобразуются к виду 8.3.
 Нужно понимать, что таблица размещения файлов МИКРОДОСа не позволяет записать на 
один диск более 128 файлов, даже если их суммарный размер будет менее 800 Кбайт. К тому же 
файловая система МИКРОДОСа не поддерживает вложенных папок. 
 Если в открываемой папке есть файл с именем boot.com (boot.rom или boot.r0m) то он 
запишется в загрузочную область (файл не должен превышать 40 КБайт). 
 
  File->Drive A: (B:)->Free Drive  A: (B:) 
 Отключить образ диска (если не стоит галочка «Read Only» то все изменения в образе диска 
сохранятся в файле). 
 
  File->Drive A: (B:)->Read Only 
 Разрешение/запрет изменения файла образа диска *.fdd. (Имейте в виду, что все изменения в 
образе диска сохраняются в файл только по окончанию работы с ним, т.е. при смене образа, его 
извлечении, закрытии эмулятора, и.т.п. поэтому я рекомендую не снимать галочку «Read only», до 
тех пор, пока не появится необходимость сохранить изменения). 
   
  File->Without FDD Controller 
 Отключить эмуляцию FDD контроллера. 
 
  File->External ROM->Open EROM… 
 Загрузка программ *.rom, *.r0m в память внешнего модуля МППЗУ. (Если в МППЗУ загружена 
программа, то чтение R-Sound карты блокируется т.к. порты МППЗУ и R-Sound конфликтуют). 
 
  File->External ROM->Clear EROM 
 Очистка внешнего модуля МППЗУ. 
 
  File->RAM Drive->Open EDD Image… 
 Загрузка в память электронного диска образов *.edd, *.img (далее при запуске эмулятора образ 
будет автоматически загружаться, пока не будет отключен командой “ File->RAM Drive->Clear 
RAM Drive”). Имейте в виду, что образ всегда подключен в режиме «только чтение», поэтому при 
необходимости сохранить изменения пользуйтесь опцией «File->RAM Drive->Save As…». 
 
  File->RAM Drive->Save As… 
 Сохранение содержимого памяти электронного диска в файл образ *.edd. 
 
  File->RAM Drive->Clear RAM Drive 
 Очистка памяти электронного диска и отключение файла образа (содержимое файла образа не 
изменяется). 
 
  File->Without RAM Drive 
 Отключить эмуляцию электронного диска. 
 
  File->Tape->Tape Image Open…   
 Открыть образ магнитофонной ленты *.wav или *.csw. (Поддерживается CSW (Compressed 
Square Wave) формат версии 1.х, а так же WAV формат: PCM 8Bit Mono). 



  File->Tape->Tape Player - Start/Stop 
 Запустить/остановить проигрыватель образов магнитофонной ленты. 
 
  File->Tape->Auto Play 
 Включить автоматический запуск проигрывателя образов магнитофонной ленты сразу после 
открытия файла *.wav; *.csw. 
 
  File->Tape->To Force CPU Speed 
 Включить форсирование скорости процессора для ускорения загрузки образов магнитофонной 
ленты.  
 
  File->Tape->Support CAS Files 
 Включение/отключение поддержки CAS (*.cas, *.rk, *.rkb) файлов. (Инициализация сделана 
через файл cas.ini. Включение этой опции существенно снижает быстродействие эмулятора!). 
 
  File->Memory Manager… 
 Открывает менеджер памяти, в котором можно сохранить выделенную область памяти в файл, 
либо загрузить блок данных из файла по заданному адресу.  
 
  File->Save State As… 
 Сохранить состояние программы и эмулятора в файл *.sta, под новым именем. (Эта опция не 
работает в режиме начального загрузчика). 
 
  File->Save State 
 Сохранить состояние программы и эмулятора в одноименный файл *.sta. (Эта опция не 
работает в режиме начального загрузчика). 
   
  File->Restore State 
 Восстановить сохраненное состояние программы и эмулятора из одноименного файла *.sta. 
(Имейте в виду, что для дисковых программ необходимо, чтобы соответствующий образ диска 
был предварительно открыт). 
 
  File->Undo Restore State 
 Вернуть предпоследнее сохранение состояние программы и эмулятора (сделано для защиты от 
случайного сохранения опцией «Save State»). 
 
  File->Auto Save/Restore State on Exit/Start 
 Автоматическое сохранение состояния при закрытии эмулятора для автоматической загрузки 
при следующем запуске эмулятора. 
 
  File->Audio Capture… 
 Захват звука и запись в файл *.wav в формате PCM 44100Hz 8Bits Stereo. Файл создается в 
папке «CAPTURE», которая находится в папке с эмулятором. (Имейте в виду, что если стоит 
галочка «For Tape», то запись ведется только с канала PCM (бипер) в формате PCM 22050Hz 8Bits 
Mono, этот режим сделан специально для записи образов кассет). 
 
  File->Video Capture… 
 Захват видео и запись в файл *.avi в форматах кодеков установленных в системе. Файл 
создается в папке «CAPTURE», которая находится в папке с эмулятором. (Видео файл создается 
без звуковой дорожки, если предварительно была включена опция “Auto Start Audio Capture” то 
дополнительно к видео файлу создастся файл с синхронной аудио дорожкой *.wav). 
 



  File->AY Registers Capture… 
 Захват потока данных регистров AY-3-8910 в файл *.ayr. Файл создается в папке «CAPTURE», 
которая находится в папке с эмулятором. Принцип захвата заключается в следующем: каждое 
прерывание (1/50 сек.) происходит запись значений регистров AY-3-8910 в файл. Структура файла 
следующая: Первые 14 байт строка в формате ASCII “AY Reg Stream “, далее идут блоки по 14 
байт содержащие значения регистров R0,R1,…,R13 в каждом прерывании (кадре). Есть одна 
особенность: если регистр R13 был обновлен в текущем прерывании, то в соответствующий блок 
записывается его значение, если R13 не обновлялся, то вместо его значения в блок записывается 
константа 255. 
 
  File->File Associations… 
 Зарегистрировать (отменить) поддерживаемые эмулятором типы файлов в системе, для того 
чтобы иметь возможность запускать их по двойному клику прямо из проводника Windows. К тому 
же эмулятор поддерживает технологию Drag And Droop. 
 

* CPU * 
 
  CPU->Options… 
 Открывает окно с вкладками, на которых можно настроить следующее: 

1. Уровень громкости звука; COM порт для перехвата потока данных к звуковому чипу 
AY/YM; Разрешение монитора для полноэкранного режима. (Если включена галочка 
«Desktop Resolution», то будет использоваться разрешение рабочего стола); Параметры для 
кассетного проигрывателя (Смещение точки нуля компаратора; Смещение скорости 
лентопротяжки); Тактовую частоту процессора (Other CPU Clock); 

2. Настроить раскладку клавиатуры с возможностью сохранения раскладок в файл, а так же 
их загрузки из файла; 

3. Назначить кнопкам мыши некоторые специальные функции, или привязать их к нажатиям 
каких либо клавиш «вектора»; 

4. Настроить раскладку для джойстика так же с возможностью сохранения в файл и загрузки 
из файла. Предусмотрена возможность связать реальный джойстик с виртуальными 
джойстиками. Если в системе установлено несколько джойстиков, то необходимо так же 
выбрать его ID номер; (Недоступно если в системе нет ни одного джойстика). 

5. Просмотр/Изменение Палитры (Доступно только в режиме эмуляции «Вектор06ц» или 
«ПК-6128ц»). 

 
  CPU->Keyboard->QWERTY/JCUKEN 
 Выбор типа клавиатуры: QWERTY или JCUKEN. 
 

CPU->CPU Type… 
 Выбор эмулируемого процессора: КР580ВМ80А (i8080А), КР580ВМ1, КР1821ВМ85А (i8085A) 
или Z80A. 
 
  CPU->CPU Speed… 
 Выбор скорости (тактовой частоты) процессора из вариантов: Low, Normal, High, Fast, или 
Other. (Внимание! Частота процессора никак не влияет на частоту прерывания. Для Other 
скорость процессора задается в окне «CPU->Options…»). 
 

CPU->Pause/Continue 
 Включение/выключение паузы. 
 
 
 



  CPU->Reset 
 Сброс эмулятора и запуск начального загрузчика. (Аналогично нажатию [ВВОД]+[БЛК] на 
«Векторе»). 
 
  CPU->Start/Restart 
 Сброс эмулятора и запуск (перезапуск) программы загруженной в памяти эмулятора 
(Аналогично нажатию [СБР]+[БЛК] на «Векторе»). 
 
  CPU->Auto Run 
 Включить режим автозапуска из начального загрузчика (Поддерживаются все известные 
варианты автозапуска для «Вектор06ц». (Опция не влияет на программный сброс для «Вектор-
Старт 1200» и «ПК-6128ц»). 
 
  CPU->Boot Manager… 
 Выбор начального загрузчика из имеющегося списка, либо загрузка дополнительного из файла 
*.epr, *.bin. (Некоторым загрузчикам требуется эмуляция соответствующего им железа!). 
 
  CPU->High Priority Application 
 Повысить приоритет эмулятора до высокого. 
  
  CPU->Debugger… 
 Запуск отладчика. 
 
  CPU->Profiler… 
 Открывает окно профайлера, где можно увидеть результаты профилирования для различных 
областей памяти и портов ввода/вывода, а также сохранить их в файл. 
 

* SCREEN * 
 
  Screen->Display Size… 
 Выбор предустановленных разрешений окна: Original Size; Average Size; Double Size; Triple 
Size; Full Screen; выбор пропорции экрана 4:3; а так же размер окна по выбору пользователя. 
 
  Screen->Display Frequency… 
 Выбор частоты обновления изображения. (так же этот параметр влияет на частоту прерывания 
в эмуляторе), диапазон частот лежит в диапазоне от 25 до 100 Гц. Для достижения частот выше 
частоты обновления вашего монитора, необходимо снять галочку в пункте «Screen->Rendering-
>Wait VSync». 
 
  Screen->Skip Frames… 
 Выбор режима пропуска кадров (для слабых компьютеров): автоматический, при нехватке 
графических ресурсов, либо фиксированный по выбору пользователя. 
 
  Screen->Pages Control… 
 Включение/отключение соответствующих плоскостей графического видеоадаптера «Вектора». 
 
  Screen->Display Effects… 
 Включение/отключение различных видео фильтров и эффектов, а так же надписей и 
пиктограмм, отображаемых на изображении. 
 
 
 



  Screen->Rendering… 
 Настройки рендеринга: 

1. Texturing – Вывод изображения через OpenGL методами текстурирования. (метод более 
ресурсоемкий по сравнению с Pixeling, но дает дополнительные возможности, такие как 
сглаживание, мультискрин). 

2. Pixeling – Вывод изображения через OpenGL методом прямого обращения к пикселям. 
(метод более быстрый по сравнению с Texturing, но с ним недоступны некоторые видео 
фильтры и эффекты). 

3. Stop at an Inactive Window – останавливать эмулятор при его неактивном окне. 
4. Wait VSync – Синхронизировать рендеринг изображения с частотой монитора. 
5. High Quality – Более высокое разрешение текстуры, повышает качество изображения, но 

увеличивает нагрузку на ресурсы компьютера. (не рекомендуется включать на слабых 
машинах). 

6. Emulate Bugs Programming Palette – Эмулировать ошибку программирования палитры. 
7. Disable Vertical Scrolling – принудительное отключение вертикального скроллинга 

дисплея. 
8. Disable Change Palette – Запрещает программное изменение палитры (Запрет не действует 

на редактор палитры в «CPU->Options->Palette»). 
9. Auto Load the Default Palette – Загружать предустановленную таблицу палитры перед 

открытием *.rom и т.п. файлов. 
 
Screen->Hardware… 

 Выбор эмулируемого железа, т.е. видеоадаптер и другая аппаратура эмулируется в режиме 
«Вектор06ц» или его клонов: «Криста-2», «Вектор-Старт 1200», «ПК-6128ц». 
 
  Screen->Screen Mode->Set Screen Mode 256х256 
 Видеоадаптер «Вектора» принудительно переключается в режим 256х256 точек, но при этом 
остается программно управляемым. 
 
  Screen->Screen Mode->Set Screen Mode 512х256 
 Видеоадаптер «Вектора» принудительно переключается в режим 512х256 точек, но при этом 
остается программно управляемым. 
 
  Screen->Screen Mode->Disable Change Screen Mode 
 Видеоадаптер «Вектора» остается в текущем видео режиме экрана и больше не реагирует на 
команды выполняемой программы до тех пор, пока данная опция не будет отключена (при этом 
опции принудительного переключения видеорежима «Set Screen Mode 256х256» и «Set Screen 
Mode 512х256» остаются доступными). 
 
  Screen->Screen Shot 
 Сделать снимок экрана (Screenshot). 
 

* SOUND * 
 
  Sound->Standard Channels… 
 Включение/отключение стандартных звуковых каналов: PCM (бипер) и каналов 0, 1, 2, таймера 
ВИ53 (i8253), а так же щелчков реле. 
 
  Sound->AY/YM Sound Card->Card Type->Sound Tracker/R-Sound/None 
 Выбор типа звуковой карты: Sound Tracker или R-Sound, либо вообще их отключение. 
 
 



  Sound->AY/YM Sound Card->Sound Chip->AY-3-8910/YM2149F 
 Выбор звукового чипа AY-3-8910/YM2149F. 
 
  Sound -> AY/YM Sound Card ->Mixer->ABC/ACB/…/Mono 
 Выбор режима микширования каналов AY-3-8910/YM2149F. 
 
  Sound ->Covox 
 Включение/отключение эмуляции Covox (внешний ЦАП). 
 
  Sound ->Filters->LF Filter 
 Включение/отключение ФНЧ (Фильтра низкой частоты) частота среза равна 20 КГц. 
 
  Sound ->Filters->i8253 Filter Noise 
 Включение/отключение фильтра тресков и шумов для таймера ВИ53 (i8253) 
 
  Sound->Mute 
 Отключение всего звука. 
 
 
 
 Внимание! Для качественной эмуляции растровых и мультиколорных эффектов необходимо 
чтобы CPU Speed был в режиме Normal и тип процессора соответствовал тому, для которого 
была написана программа с данными эффектами (это обычно КР580ВМ80А). Во избежание 
артефактов на изображении для CPU Speed отличных от Normal сделана упрощенная эмуляция 
растровых эффектов, даже если выбрана CPU Speed Other = 3.000 MHz.   



Пример запуска программ с образа диска *.fdd: 
 

1. Отключить опцию CPU->Auto Run; 
2. Открыть образ диска через опцию File->Drive A:->Open FDD Image…; 
3. Очистить содержимое RAM диска опцией File->RAM Drive->Clear RAM Drive; 
4. Выбрать в пункте меню CPU->Boot Manager… загрузчик TIMSoftBoot; 
5. Клавишей [F11] перезапустить загрузчик; 
6. Через несколько секунд, когда карта загрузки частично заполнится нажать [F12], чтобы 

диск автоматически стартовал. 
 

 Данный метод подходит, если диск загрузочный и образ электронного диска не подключен. 
Если по вышеизложенному методу запустить образ диска не получилось, привожу метод второй, 
более сложный: 
 

1. Отключить опцию CPU->Auto Run; 
2. Загрузить образ электронного диска RDS_V201.edd (как это сделать см. выше пункт File-

>RAM Drive->Open EDD Image…). Образ лежит в папке эмулятора «EDD»; 
3. Выбрать в пункте меню CPU->Boot Manager… загрузчик TIMSoftBoot; 
4. Клавишей [F11] перезапустить загрузчик (карта загрузки при этом частично заполнится); 
5. Открыть образ диска через опцию File->Drive A:->Open FDD Image…; 
6. Для запуска ОС c электронного диска нажать [F12]; 
7. Далее после запуска ОС набрать команду DIR для отображения содержимого образа диска; 
8. Для запуска программы набрать ее имя, можно без расширения. (программы 

предназначенные для запуска, обычно имеют расширение *.COM); 
 

Пример загрузки программ из звуковых образов кассеты *.wav; *.csw: 
 

1. Выбрать в пункте меню CPU->Boot Manager… загрузчик TIMSoftBoot; 
2. Нажать клавишу [F1] и удерживая ее, клавишей [F11] перезапустить загрузчик, так чтобы 

появилась пиктограмма аудио кассеты; 
3. Открыть предварительно подготовленный файл *.wav (только PCM 8Бит Моно) или *.csw 

через опцию File->Tape->Tape Image Open…; 
4. Комбинацией [Alt]+[F6] или через пункт меню File->Tape->Tape Player - Start/Stop 

Включить воспроизведение звукового файла (при этом должно начаться звуковое 
сопровождение). При достаточном качестве звукозаписи в файле *.wav карта загрузки 
начнет медленно заполняться (Внимание! Если включена опция «Auto Play» то пункт 4 
пропустить); 

5. По окончанию загрузки нажать клавишу [F12] для запуска программы, либо 
воспользоваться пунктом File->Save As… для ее сохранения на диск в формате *.rom или 
ему подобном. 

 
Пример загрузки программ с внешнего модуля МППЗУ 32к: 

 
1. Загрузить файл *.rom во внешний модуль МППЗУ опцией File->External ROM->Open 

EROM… (размер файла *.rom недолжен превышать 32кб.); 
2. Выбрать в пункте меню CPU->Boot Manager… загрузчик TIMSoftBoot; 
3. Нажать клавишу [F2] и удерживая ее, клавишей [F11] перезапустить загрузчик, так чтобы 

появилась пиктограмма микросхемы. (карта загрузки при этом частично заполнится); 
4. Нажать клавишу [F12] для запуска программы. 
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